اخبار پویاسازان


اطلاعیه ارتقاء نسخه PHP بر روی سرور های آمریکا


به اطلاع کلیه کاربران محترم شرکت پویاسازان فناوری اطلاعات می‌رساند با توجه به به روز رسانی جدید برای Cpanel که به همراه آن نسخه EasyApache 4 نیز نصب میشود و در این نسخه حداقل نسخه PHP مورد پشتیبانی 5.4 میباشد، به روز رسانی کلیه سرور های لینوکس آمریکا به این نسخه از EasyApache از تاریخ 15 آبان ماه 1394 لغایت 25 آبان ماه 1394 انجام میشود.

لازم به ذکر است با توجه به تفاوت های ساختاری بین سری 5.3 و 5.4 چنانچه اسکریپت یا سیستم مدیریت محتوای مورد استفاده توسط شما تنها مبتنی بر سری 5.3 PHP ساخته شده باشد ، این تغییر ممکن است آن را با خطاهایی همراه سازد ، لذا جهت اطمینان از عدم وقوع این مشکل ، حتماً در بازه زمانی باقیمانده اقدام به دریافت مشاوره از برنامه نویس یا پشتیبان سیستم مدیریت محتوای خود فرمایید تا در صورت امکان ، آن را به نسخه مطابق با و یا بالاتر PHP 5.4 ارتقاء دهید.

نکته بسیار مهم آنست که نسخه جدید PHP پشتیبانی کاملی از نسخ قبلی ندارد و کدهای قبلی ممکن است بر روی آن به درستی کار نکنند. وردپرس ، جوملا و دیگر نرم‌افزارهای جدید و بروزشده مشکلی با این تغییر نخواهند داشت اما نسخه‌های قدیمی جوملا یا تالارهای گفتمان قدیمی ممکن است دچار مشکل شوند.

کاربران محترم باید توجه داشته باشند که به دلایل امنیتی به تعویق انداختن ارتقاء سرور مقدور نیست و تاریخ اعلام شده تمدید نخواهد شد ، لذا پس از این تاریخ هرگونه مشکل احتمالی در وب سایت های مشتریان بر عهده ایشان بوده و پویاسازان مسئولیتی در قبال آن نخواهد داشت.
همچنین لازم به ذکر است در نسخه جدید Cpanel امکان استفاده همزمان از 3 نسخه 5.4 و 5.5 و 5.6 از PHP امکان پذیر میشود.

لطفا در صورت وجود هرگونه سوال در این زمینه فقط با ایمیل support@pouyasazan.org در ارتباط باشید.

با احترام
واحد اطلاع رسانی پویاسازان

۲۳/۷/۱۳۹۴   | ۱۹۶۰


نماد اعتماد الکترونیک
back to top